Softodrom.ru - Каталог программ для Windows

Лучшие программы для Windows и UNIX Скачай Испытай Обсуди

ПОИСК

по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Новое:
  • Как в Windows XP установить протокол NetBEUI?
  • После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...
  • Как в Windows XP запускать программы как сервисы?
  • Как включить режим UDMA66 на материнских платах, собранных на чипсетах Intel?
  • Как отключить службу QoS (Quality of Service). Правда ли, что она ограничивает скорость сети?
  • Как удалять файлы, минуя "мусорную корзину"?
  • Можно ли в WinXP снимать задачи из командной строки?
  • Как автоматизировать вход в систему - без ввода логина и пароля?
  • Как восстановить повреждённый загрузчик XP?
  • Где хранится код активации Windows XP?
Общие вопросы
  • Что такое Windows XP?
  • Что включает в себя Windows XP Plus Pack?
  • Предусматривается ли установка Windows XP сверху на уже установленную, например, Windows 2000?
  • Чем отличается WinXP Professional от WinXP Home?
  • Как русифицировать английскую Windows XP?
  • Есть ли в Windows XP средства для работы с видео?
  • Как в XP обстоят дела с совместимостью со старыми программами (играми)?
  • Как работает шифрование файлов?
  • Что такое Remote Assistance?
  • А Remote Desktop?
  • Что за новый подкаталог WinSxS с dll-ками появился в каталоге Windows? Для чего он?
  • Что такое NTFS?
  • В чем отличие NTFS4 от NTFS5?
  • Стоит ли переходить на NTFS? И как это сделать?
  • Что такое boot defrag и для чего это?
  • Можно ли установить WinXP так, чтобы остался и Windows 98?
  • Как корректно удалить WinXP/2K и восстановить Windows 95 или 98?
  • Что за режим выключения компьютера - Hibernate?
  • Что такое иконки Windows XP?
  • Можно ли в WinXP снимать задачи из командной строки"?
  • Как переименовать сразу несколько файлов?
  • Допускается ли, не перелогиниваясь, запускать программы от имени другого пользователя?
Настройка системы
  • Можно ли уменьшить размер Windows XP?
  • А что это в XP хелп такой урезанный?
  • Что можно предпринять для оптимизации Windows XP?
  • Как удалить "скрытые" компоненты Windows XP?
  • Можно ли самому создать скин для Windows XP?
  • Можно ли заменить картинку в меню "Start" рядом с моим именем на мою фотку?
  • Позволяет ли эта версия Windows вносить изменения в файл config.sys?
  • Какие из драйверов больше подходят для WinXP - от NT или 2K?
  • Для чего нужна вкладка Compatibility в свойствах exe-файла?
  • Хочу заменить файл в папке System32, а Windows ругается и не дает. Что делать?
  • Где находятся те утилиты, о которых говорится в обзоре Windows XP?
  • Вроде бы Microsoft уже выпустила пакет дополнений для Windows XP. Откуда его можно скачать?
  • Можно ли в XP снимать с аудио-CD цифровой звук?
  • Как запустить дефрагментатор из контекстого меню Проводника?
  • Как выставить права пользователям, работающим на компьютере?
  • Как зайти в систему администратором (пользователь Administrator)?
  • Как включить mp3-кодирование с высоким битрейтом?
  • Как изменить интервал синхронизации системных часов компьютера с time-сервером?
  • Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?
  • Можно ли в окне "Welkome" изменить шрифты на сглаженные (cleartype)?
  • А что, в XP нет своего факса?
  • Как удалять файлы, минуя "корзину"?
  • Как переименовать папку аккаунта Administrator?
  • Как сделать, чтобы при перезагрузке стирался/создавался заново файл подкачки pagefile.sys?
  • Как мне залочить компьютер? Через Crtl+Alt+Del не получается...
  • Как сделать, чтобы зависшие и переставшие отвечать задачи убивались автоматически
  • Откуда загружаются программы при старте системы? У меня папка Автозагрузка пустая...
  • Можно ли ввести компьютер в состояние Hibernate из командной строки?
  • Как изменить time-server, используемый для подстройки системного времени?
  • Можно ли отключить сообщение о недостатке свободного места на диске?
  • Как отключить появление предложения об отправке рапорта об ошибке?
  • Можно ли сделать так, чтобы определенная папка открывалась по горячей клавише?
  • Как добавить содержимое Рабочего стола в меню Start?
  • Как (и можно ли вообще) уменьшить размеры огромных файлов Pagefile.sys и Hyberfil.sys?
  • Как удалить с рабочего стола все системные иконки, включая корзину?
  • Как отключить автозапуск компакт-дисков?
  • Куда подевалась закладка Security на NTFS-дисках и почему так упростилась закладка Sharing?
  • Как назначить диску другую букву?
  • А как обстоят дела в WinXP с переименованием загрузочного (или системного) диска?
  • Можно ли отключить отображение zip-архивов как папок?
  • Как автоматизировать вход в систему - без ввода логина и пароля?
  • Как включить режим UDMA66 на материнских платах, собранных на чипсетах Intel?
  • Как в Windows XP запускать программы как сервисы?
Windows XP и сеть
  • После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...
  • Как в Windows XP установить протокол NetBEUI?
  • Как отключить службу QoS (Quality of Service). Правда ли, что она ограничивает скорость сети?
  • Windows все время хочет обновиться и пытается лезть в Интернет. Это безобразие можно прекратить?
  • Как включить интернет-защиту?
  • Можно ли полностью отключить скрытые общие ресурсы (ADMIN$, C$ и т.д.)?
  • Как включить роутинг?
Разрешение проблем
  • Система стала глючить или пропали системные шрифты
  • Почему вместо русских букв видны какие-то закорючки?
  • DOS: русские буквы видны, а вот раскладка не переключается. Что делать?
  • Для особо забывчивых: как создать дискету для сброса пароля
  • Проблема с инсталляцией программ: программа вроде бы устанавливается, но в конце все исчезает, хотя процесс остается в памяти
  • Установка Windows 9*/Me после установки Windows XP
  • Что делать, если после перезагрузки система не находит внешний модем?
  • Почему в режиме Standby не выключаются вентиляторы на блоке питания и процессоре?
Восстановление
  • Что представляет собой система восстановления Windows XP?
  • Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?
  • Система не загружается...
  • Как добавить прав в Recovery Console?
  • Как восстановить повреждённый загрузчик XP?
  • Где хранится код активации Windows XP?
  • Можно ли в WinXP сделать загрузочные дискеты?

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев
Программирование: Янкин Н.В.


по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Общие вопросы

Что такое Windows XP?

Windowx XP - это новая операционная система, обьединяющая, по словам Microsoft, две существовавших ранее независимо друг от друга линейки Windows - "домашнюю" Windows 95/98/Me и "профессиональную" NT/2000. О моих первых впечателениях от знакомства с Windows XP можно узнать из заметки, которая так и называется - Windows XP: что это такое и с чем ее едят.

Предусматривается ли установка Windows XP сверху на уже установленную, например, Windows 2000?

Конечно, и при этом будут сохранены все существующие настройки. Операционные системы Windows NT/2000 можно обновить до Windows XP Professional, а Windows 98/98SE/Me - до любой из двух редакций Windows XP (Home Edition и Professional). Windows XP, кстати, будет продаваться как в "полном" варианте, так и в виде обновления (стоимостью подешевше). Единственное условие - обновляемая операционная система должна иметь тот же язык интерфейса, что и устанавливаемая Windows XP, иначе обновление будет невозможно.

К сожалению, пользователи Windows 3.1, Windows 95 и Windows NT 3.51 лишены возможности обновить свою систему до Windows XP - установить Windows XP они, конечно, смогут, но имевшиеся настройки не сохранятся, да и ранее инсталлированные программы придется переустанавливать.

Чем отличается WinXP Professional от WinXP Home?

Чего же нет в Windows XP Home Edition? - А вот чего:

  • Отсутствует удаленный доступ к компьютеру, что делает невозможным подключение в удаленном режиме к компьютеру, работающему под управлением Windows XP, с любого другого компьютера под управлением Windows (а ведь эта функция очень полезна в случае необходимости работать с приложениями и данными, если часто находишься вдалеке от "основного" компьютера)
  • Нет доступа к файлам и папкам, хранящимся на общем сетевом диске даже во время отключения компьютера от сервера (эта фича, как я понимаю, нужна только в локальной сети)
  • Удалены функции по работе с серверами Microsoft Windows Server и системами управления предприятиям ("Home" ведь не является предприятием)
  • Еще один минус - отсутствует многоязычный пользовательский интерфейс, позволяющий менять язык интерфейса, чтобы работать с локализованными диалоговыми окнами, файлами справки, словарями, средствами проверки правописания и т.п. Другими словами, в WinXP Pro заложена возможность менять интерфейс самой операционной системы: сел за компьютер, к примеру, китаец, кликнул пару раз, и английская версия XP превратилась в китайскую (но это можно проделывать только в том случае, если будут установлены специальные языковые модули - в инсталляционном CD их нет).
  • Отсутствует возможность использования шифрования данных и управления доступа к ним
  • Нет масштабируемой поддержки процессора (Pro - вплоть до поддержки двусторонней многопроцессорной обработки), но у многих ли из нас многопроцессорные системы?
Обобщая: из Windows XP Home Edition исключены те компоненты, которые, по разумению Microsoft, не нужны при домашнем использовании операционной системы. Насколько верно выбраны те компоненты, что "не нужны", судить не берусь, но разница в стоимости двух редакций Windows XP настолько ощутима, что наверняка стоит задуматься, а так ли уж нужен, к примеру, удаленный доступ к компьютеру...

Как русифицировать английскую WinXP?

Частично (процентов на сорок) русифицировать интерфейс английской версии Windows XP Professional можно патчем, меняющим языковые ресурсы в парочке файлов. Подробности - здесь.

Есть ли в Windows XP средства для работы с видео?

Кроме фирменного медиаплеера (Windows Media Player 8), воспроизводящего локальные и потоковые файлы Windows Media, а также многие другие форматы аудио и видеофайлов, в Windows XP входит новый компонент - Movie Maker, предназначенный для создания и редактирования цифровых видеофильмов. Ну и, конечно, есть возможность пользоваться сканером, а также перегонять фотографии из цифрового фотоаппарата на жесткий диск компьютера.

Как в XP обстоят дела с совместимостью со старыми программами (играми)?

Несмотря на то, что ядро NT, являющееся основой Windows XP, накладывает некоторые ограничения на совместимость со старым программным обеспечением, однако (по сравнению с Windows 2000) положение явно улучшилось. Например, в старых досовских игрушках появился звук. Кроме этого, стоит отметить поддержку эмуляции Sound Blaster 2 и General MIDI, поэтому в Windows XP без проблем будут работать со звуком такие "старички", как, к примеру, Duke Nukem 3D, Warcraft 1/2 или Dune 2. Наконец, не стоит забывать о таком нововведении, как режим совместимости...

Как работает шифрование файлов?

По умолчанию служба шифрования, имеющаяся в Windows XP, запускается автоматически при загрузке операционной системы, поэтому никакого дополнительного ее включения не требуется. А вот для того, чтобы зашифровать конкретный файл или папку, нужно проделать следующее: щелкаем правой кнопкой мыши по файлу/папке, выбираем в меню пункт Properties и нажимаем в появившемся окошке (на вкладке General) кнопку Advanced. После открытия новой вкладки отмечаем там пункт "Encrypt contents to secure data". Маленькое замечание: шифровать допустимо только те файлы и папки, которые размещены на дисках с файловой системой NTFS; необходимо помнить, что шифруются только несжатые данные (в том случае, если зашифровать сжатый файл или папку, они будут разжаты); не допускается шифрование файлов, отмеченных как системные, как нельзя зашифровать и системную директорию (по умолчанию это папка c:/windows). И еще: не удивляйтесь, что внешне после зашифровки файла или папки ничего не изменится - хозяин зашифрованных данных может обращаться с ними точно так же, как и с незашифрованными, а вот для всех остальных, кто войдет в систему под другим логином, зашифрованные данные окажутся недоступными...

Что такое Remote Assistance?

Remote Assistance (удаленная помощь) - еще одно новшество, включенное в Windows XP (по-моему, только в версию Pro). Теперь представители группы техподдержки могут не выезжать к пользователю, чтобы, например, научить, как менять разрешение экрана, а подключиться к его компьютеру и рассказать и, если вы разрешите, показать, как это делается - то есть удаленно настроить компьютер или устранить какую-либо неполадку в операционной системе. Естественно, удаленная помощь может быть оказана не только специалистами техподдержки, но и, например, вашим приятелем, разбирающемся в компьютерах.

А Remote Desktop?

Remote Desktop (удаленный рабочий стол) позволяет получить практически полное управление над удаленным компьютером. Весьма полезная вещь, если вы, находясь, к примеру, дома, решите поработать на компьютере, установленном на работе...

Что за новый подкаталог WinSxS с dll-ками появился в каталоге Windows? Для чего он нужен?

WinSxS, или Windows Side by Side (бок о бок), является еще одним новшеством Windows XP. Microsoft, озаботившись криворукостью программистов, создала систему, позволяющую сохранять несколько версий одинаковых библиотек (DLL) и использовать при необходимости именно ту, что требует конкретная программа. Дело в том, что некоторые программы почему-то считают, что только они имеют нужную версию DLL, и перезаписывают при инсталляции даже более новую версию библиотеки, что может привести ко всякого рода неприятностям, поэтому, если какая-нибудь программа вздумает беспричинно заменить уже имеющуюся в системном каталоге DLL, операционная система поместит сомнительную библиотеку в специальную папку (WinSxS), а дурная программа так и останется уверенной, что сделала свое черное дело...

Что такое NTFS?

NTFS - это файловая система, которую не понимает Windows 9*/Me. Учитывая, что NT - это сокращение от английского "новая технология", можно предположить, что в NTFS есть много чего хорошего, и это действительно так. Вот лишь краткий перечень преимуществ NTFS:

- возможность работать с большими дисками, причем с действительно большими - теоретически NTFS поддерживает диски размером до 16777216 терабайт ("теоретически" потому, что диски такого огромного размера вряд ли появятся даже в не очень ближайшем будущем)

- надежность. Не вдаваясь в подробности, подчеркну, что NTFS устроена так, что в случае копирования, перемещения или удаления файлов (папок) гарантируется абсолютная сохранность данных. Проще говоря, чтобы не случилось, будь то сбой питания во время выполнения задачи или какая-то другая напасть вроде кривого пальца, нажавшего в самый неподходящий момент кнопку Reset, операционная система после перезагрузки будет работать без ошибок, а, к примеру, перемещенный только наполовину до момента аварии файл останется целым и невредимым. Кроме этого, NTFS имеет не одну, а две копии аналога FAT (MFT - Master File Table), и при повреждении одной копии система при перезагрузке использует другую - целую - копию MFT, одновременно создавая (с учетом повреждений) ее копию.

Короче говоря, надежность и устойчивость - это главные отличительные черты NTFS. А из "мелочей" - зищищенность, включающая в себя возможность определить каждому пользователю его права буквально на каждый файл (открытие, закрытие, чтение, запись), а также допустимость шифрования файлов.

В чем отличие NTFS4 от NTFS5?

В XP используется файловая система NTFS5. Ее основное отличие от NTFS4, используемой в Windows NT, заключается в дальнейшем расширении функциональности, и прежде всего - в возможности квотирования. Квотирование позволяет ограничить каждому пользователю максимальный обьем дискового пространства, которое он сможет использовать. Выделено ему, к примеру, 50 мегабайт, и больше "захапать" ему никак не удасться.

Полезность этой функции наверняка оценят в крупных организациях /сетях (диски ведь не безразмерные), да и дома такая опция может пригодиться: выделил, например, ребенку столько-то места, и можно быть уверенным, что диск не будет захламлен тоннами мусора.

Другими характерными чертами NTFS5 являются возможность поиска файла по имени его владельца, а также появление функции точки монтирования (junction point), позволяющей присоединить любой диск в любое место файловой системы. Например, можно присоединить диск D в каталог Documents, который находится на диске С, и тогда, зайдя в папку С:\Documents, мы увидим содержимое корневого каталога диска C (что-то я перемудрил с каталогами/папками, поэтому для новичков поясню, что каталог и папка - это одно и то же). Но самое интересное заключается в другом: убрав через Computer management / Disk Management букву, присвоенную этому диску, мы получим один обьединенный диск - диск С. Монтирование / размонтирование производится через меню Change disk letter and path, в которое можно попасть через Administrative Tools / Computer management / Disk Management

Стоит ли переходить на NTFS? И как это сделать?

Вопрос, конечно, интересный... NTFS из-за своей системы безопасности, вернее, из-за необходимости загружать специализированные службы, поддерживающие ее, работает несколько медленнее, чем FAT; кроме этого (и что даже важнее), NTFS занимает больше памяти, поэтому, если оперативной памяти меньше 128 мегабайт, переходить на NTFS не стоит. А вот если оперативки больше, то и впрямь стоит задуматься о преимуществах NTFS...

А теперь - о том, как перейти с FAT на NTFS и при не потерять данные. Во-первых, при установке WIndows XP это можно сделать автоматически - в соответствующий момент ответив утвердительно на соответствующий вопрос. Можно преобразовать FAT16 (или FAT32) в NTFS и позже - воспользовавшись командой CONVERT. Синтаксис этой команды такой:
convert [диск] /fs:ntfs [/v]
где V - параметр, позволяющий не гадать при следующей перезагрузке системы, идет конвертация или нет, а видеть соответствующие сообщения о происходящем процессе на экране.

Кроме встроенных средств Windows XP, для преобразования FAT в NTFS можно воспользоваться замечательной программой Partition Magic, позволяющей к тому же при необходимости выполнить и обратное преобразование - из NTFS в FAT, и тоже без потери данных.

Что такое boot defrag и для чего это?

Суть boot defrag заключается в дефрагментации тех файлов, что нужны для старта операционной системы. Выключение этой функции позволит на некоторое время уменьшить время загрузки, но со временем она будет становиться все медленнее... Все равно хотите отключить? - Пожалуйста: открываем реестр, идем в HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Dfrg \BootOptimizeFunction и меняем там значение параметра Enable. Y - дефрагментация включена, N - выключена.

Можно ли установить WinXP так, чтобы остался и Windows 98?

Windows XP такое позволяет - в этом случае в начальной стадии загрузки компьютера можно будет выбирать, какая операционная система должна быть загружена. Для этого следует в начале инсталляции Windows XP отказаться от предложения обновить систему и указать другой каталог для установки Wundows XP - не предлагаемый по умолчанию каталог Windows (где у вас уже стоит Windows 9*), а, например, WinXP.
Несколько замечаний:
- нежелательно устанавливать Windows XP второй системой на тот же раздел жесткого диска, где уже стоит Windows 9*/Me (Windows XP при инсталляции перезапишет некоторые файлы их новыми версиями, в результате чего в Windows 9*/Me кое-что перестанет работать - например, Outlook Express)
- установка Windows XP второй операционной системой возможна только в том случае, если имеющийся у вас инсталляционный CD предназначен для установки Windows XP "с нуля", а не для обновления операционной системы.

Что за режим выключения компьютера - Hibernate?

Hibernate (в русской версии XP - "спящий режим") - это режим "засыпания" операционной системы, заключающийся в том, что все содержимое оперативной памяти сохраняется на жестком диске, монитор и жесткие диски отключаются, после чего компьютер выключается. Главной особенностью этого режима является то, что при перезапуске компьютера состояние рабочего стола полностью восстанавливается, т.е. система полностью восстанавливает свое состояние, имевшееся на момент "засыпания". Проще говоря, на чем вы остановились, выключив компьютер его переводом в спящий режим, с того же самого места и сможете продолжить свою работу или игру: все приложения будут работать точно также, как и до "спячки" - будто ее и не было вовсе.

Можно ли в WinXP снимать задачи из командной строки?

Для этого следует набрать
taskkill /pid и номер задачи или просто
tskill и номер процесса.
Номер можно узнать, набрав команду tasklist - еще одну новую команду, которая к тому же сообщит многое другое о том, что происходит в операционной системе.

Как переименовать сразу несколько файлов?

Выделяем в окне группу файлов, щелкаем по любому из них правой кнопкой и, если нужно, переименовываем. Все выделенные файлы получат имя указанного файла с индивидуальным номером в скобках.
Кстати в Windows XP есть еще одна любопытная опция - возможность "разложить" значки в папках по алфавиту: после выбора в меню View -> Arrange Icon By... -> Show In Groups значки окажутся организованными в упорядоченные по алфавиту группы.

Допускается ли, не перелогиниваясь, запускать программы от имени другого пользователя?

В Windows XP такое предусмотрено, но только в том случае, если известен пароль этого пользователя: щелкаем на исполняемом файле программы (или ее ярлыку) правой кнопкой, выбираем Run As... (Запуск от имени) и вводим имя пользователя и пароль - они будут действовать до окончания текущего сеанса работы. Одно из применений такой опции - получение прав администратора для установки новой программы.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев


по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Настройка системы

Можно ли уменьшить размер Windows XP?

В том случае, если уже установлено все оборудование, можно удалить папку %SystemRoot%\Driver Cache\i386\ (т.е. по умолчанию C:\Windows\Driver Cache\i386\). Правда, в этом случае при добавлении любого нового оборудования Windows будет запрашивать установочный CD.
Можно также отключить System Restore, удалив тем самым информацию, которая хранится в папке System Volume Informatiоn.

И еще одну папку можно удалить - %SystemRoot%\system32\dllcache\ (в ней хранятся защищенные системные файлы, используемые для автоматического восстановления оригиналов в случае их повреждения). Кстати, по умолчанию размер этой папки - 400 мб (он задается в реестре параметром SFCQuota (0xFFFFFFFF), находящемся в ключе HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon), но его можно изменить до нуля командой sfc: sfc /cachesize=0 (если поставить, например, 10, то размер папки уменьшится до 10 мб)

А что это в XP хелп такой урезанный?

На самом деле система помощи в Windows XP даже более подробная, чем, например, в NT, но она разделена на несколько частей - та, что появляется через через пункт Help and Support кнопки Start, предназначена, выражаясь помягче, для неквалифицированных пользователей. Этот "главный" хелп не содержит сведений об очень многих аспектах управления операционной системой, поэтому, чтобы почерпнуть действительно важную информацию, придется прогуляться по файлам помощи отдельных апплетов, например тех, что находятся в разделе Computer Management (Start / Control Panel).

Что можно предпринять для оптимизации Windows XP?

Для начала - отключить ненужные системные службы (сервисы), ускорив тем самым работу системы. Заодно и памяти немного освободиться...

Вот список служб, которые, в принципе, можно безбоязненно отключить:

  • Automatic Updates (Автоматичесткое обновление). Учитывая, что обновлять систему можно и вручную, имеет смысл отключить эту службу. Особенно в том случае, если нет постоянного соединения с Интернетом. Следует только не забыть не только отключить службу, но и отменить Automatic Updates в одноименной закладке System Properties.
  • Computer Browser. Занимается обновлением списка компьютеров в сети. При отсутствии сети не нужна.
  • Cryptographic Service. Служба безопасного обмена ключами и шифрования передаваемых данных в локальной сети. Если локальной сети нет, то эту службу можно отключить, если сеть есть - думайте сами...
  • DHCP client. Занимается автоматическим распределением IP-адресов. Если сети нет (ни локальной, ни Интернета - даже через модем), то эта служба не нужна.
  • Event Log. Ведет лог системных, программных событий и событий в системы безопасности. В принципе, можно отключить. Ничего страшного не произойдет.
  • Messenger. Отвечает за прием и отправку сообщений, посланных администратором. При отсутствии сети (и администратора) абсолютно бесполезна.
  • Network Connections. Управление всеми сетевыми соединениями. Если нет сети (в том числе нет и Интернета), то эта служба не нужна.
  • Print Spooler (Спулер печати). Если принтера нет, то он не нужен.
  • Portable media serial number. Отвечает за получение серийного номера переносного музыкального устройства, подключаемого к компьютеру. Лично у меня ничего подобного нет...
  • Protected Storage. Защита важных данных, в т.ч. ключей пользователей; запрещает неавторизированный доступ. Если нет сети (в том числе и Интернета), то эту службу можно отключить (если безопасность не волнует - можно отключить и при наличии сети).
  • Remote Registry Service. Предназначена для удалённого управления реестром (нужна только администраторам сети).
  • System Event Notification. Отслеживает системные события. Если все уже настроено и нормально работает, можно отключить.
  • SSDP Discovery. Обеспечивает работу подключаемых устройств, поддерживающих UPnP (универсальная система Plug & Play, которая, по задумке, должна связывать компьютер с самой различной бытовой техникой, вроде пылесоса или холодильника. Мне такой техники пока не встречалось).
  • Task Scheduler. Запуск приложений в заданное время. Если эта возможность не используется, эту службу можно отключить.
  • Telephony. Взаимодействие с модемом. Нет модема - отключаем службу
  • Telnet. Обеспечивает возможность соединения и удалённой работы по протоколу telnet. Если не знаете (и не хотите знать), что это такое, то эту службу можно отключить.
  • Uninterruptible power supply. Управляет работой бесперебойных источников питания (UPS). Если UPS с обратной связью нет, то не нужна.
  • Terminal Service. Служит для подключения к компьютеру по сети и удаленного управления им. Домашнему пользователю она в общем-то ни к чему.
  • Windows time. Синхронизирует время на локальной машине и сервере; если нет time-сервера, то и служба не нужна.
  • Wireless zero configuration. Служба автоматической настройки беспроводных сетей стандарта 803.11 и 803.11b. Если беспроводной сети нет, то зачем работать этой службе?

    Подчеркну, что этот список - не окончательный, потому что необходимость той или иной системной службы определяется теми задачами, которые выполняются на конкретном компьютере, поэтому каждый должен решать сам, что можно отключить, а что нет. Главное - не переборщить, помня, что последствия необдуманных действий могут быть непредсказуемыми. И еще о последствиях. Для того, чтобы уменьшить риск "запороть" систему, имеет смысл перед началом эксперименетов со службами сделать резервную копию той ветви реестра, что отвечает за запуск системных служб: открываем regedit, идем в HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Serviсes, выбираем в меню File, а там - пункт Export Registry Key.

    Еще один метод, позволяющий ускорить работу системы и несколько освободить занимаемую ею оперативную память, заключается в отключении Dr.Watson'a, отладчика, запускаемого по умолчании при каждом сбое в работе приложений. Чтобы отключить этого "доктора", нужно будет в реестре найти ключ HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows NT \CurrentVersion \AeDebug и изменить в нем значение параметра Auto на 0. После такой модификации реестра при возникновении сбоя в работе приложения система будет предлагать либо закрыть его, либо передать отладчику для отладки (если выбрать второе, то запустится Dr.Watson и создаст лог-файл).

    Следующий этап - оптимизация интерфейса, призванная ускорить его работу. Заходим в System Properties, открываем закладку Advanced, нажимаем в разделе Performance кнопку Settings и в открывшейся вкладке Visual Effects отмечаем пункт Adjust for best performance, отключая тем самым абсолютно все эффекты. А можно отключить их и по отдельности, оставив те, без которых прожить ну никак нельзя...

    Теперь примемся за стартовое меню. Изначально оно открывается с некоторой задержкой (по умолчанию - 400 миллисекунд), регулировать которую можно, изменяя в реестре значение ключа MenuShowDelay, находящегося по адресу HKEY_CURRENT_USER \ControlPanel \Desktop. В случае установки для этого параметра значения 0 меню будет появляться без задержки.

    Там же - в реестре - находится еще один параметр, изменение которого приведет к некоторому ускорению работы интерфейса - MinAnimate, включающий анимацию при сворачивании и разворачивании окон, находится по адресу HKEY_CURRENT_USER \ControlPanel \Desktop \WindowsMetrics. Значение 1 - эффект анимации включен, 0 - выключен. Если этого ключа в реестре нет, то создайте его (тип - String). И не забудьте - для вступления подобных изменений в силу необходимо перезагрузить компьютер.

    Открытие на NTFS-разделе папок с большим количеством файлов происходит довольно медлено, потому что Windows каждый раз обновляет метку последнего доступа к файлам и на это, естественно, тратиться какое-то время. Для отключения этой функции нужно запустить regеdit и по адресу HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \FileSystem cоздать параметр типа DWord, назвав его NtfsDisableLastAccessUpdate и присвоив ему значение 1.

    Кроме всего перечисленного, для оптимизации работы системы можно воспользоваться программами, специально для этого предназначенным, например, Tweak-XP - набором из двух десятков утилит для настройки Windows XP.

    Как удалить "скрытые" компоненты Windows XP?

    В отличие от Windows 9*/NT, в процессе установки Windows XP нет возможности выбирать необходимые компоненты. На мой взгляд, это правильное решение Microsoft - сначала следует установить операционную систему со всеми ее прибамбасами, а уж затем, поработав, можно решать, что следует оставить, а что нет.

    Правда, и в этом случае получается, как сказал бы наш незабвенный Б.Н.Ельцин, в некотором роде заковыка: в окне "Add/Remove Windows Components", что присутствует в апплете "Add or Remove Programs" Контрольной панели, удалять-то практически нечего, потому что многие из составляющих Windows скрыты от шаловливых ручек не слишком опытных юзеров.

    Так что же, у этой проблемы нет решения? - Конечно же, решение есть. Открываем системную папку Inf (по умолчанию - C:\Windows\Inf), находим в ней файл sysoc.inf, открываем его и удаляем во всех строках слово HIDE. Главное при этом - оставить неизменным формат файла, то есть следует удалять только HIDE, оставляя запятые до и после этого слова.

    Для примера - исходная строка и та, что должна получиться:
    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7
    msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,,7

    Сохраняем файл sysoc.inf, открываем "Add/Remove Windows Components" и видим значительно более длинный список, чем тот, что был на этой страничке до проведения описанной выше операции. Правда, и в этом случае много удалить не получится.
    Кстати, точно также можно поступить и в случае с Windows 2000...

    Можно ли самому создать скин для Windows XP?

    Можно - недавно появилась программа Windowblinds XP, специально предназначенная для самостоятельного изменения внешнего вида Windows XP.

    Можно ли заменить картинку в меню "Start" рядом с моим именем на мою фотку?

    Можно, причем не только на свою фотографию, но и на любой другой графический файл, и сделать это очень просто: после клика по этой картинке выскочит окошко "User Аccount", в правой нижней части которого есть ссылка "Browse for more pictures" (обзор других картинок), с помощью которой и следует найти ту картинку/фотку, которая будет показываться напротив имени пользователя.

    Позволяет ли эта версия Windows вносить изменения в файл config.sys? А то в Миллениуме нельзя заставить компьютер запомнить, скажем, такую строку: files=200

    В Windows XP (как и в WinNT/2K) подобный файл называется config.nt. Он поддается модификации, в том числе и установке числа одновременно доступных файлов во время работы подсистемы MS-DOS. Следует только понимать, что в Windows XP, строго говоря, нет MS-DOS, а есть только ее эмуляция.

    Какие из драйверов больше подходят для WinXP - от NT или 2K?

    Я бы ответил на этот вопрос так: лучше всего подходят драйверы, специально написанные для Windows XP, но такой ответ, скорее всего, мало кого удовлетворит, поэтому продолжу. Как мне кажется, лучший способ подобрать недостающий драйвер - это метод научного тыка, заключающийся в последовательной установке всех драйверов, какие имеются, тем более что в Windows XP предусмотрен очень простой способ возврата к старой версии драйвера - одним нажатием на кнопку "Roll Back Driver", которая находится на вкладке "Driver" окна со свойствами соответствующего устройства.

    Для чего нужна вкладка Compatibility в свойствах exe-файла?

    Эта вкладка предназначена для "обмана" программ.
    Учитывая, что Windows XP является вроде как бы "гибридной" операционной системой, на которую будут переходить пользователи и Windows 98, и Windows NT, и Windows 2000, Microsoft приняла решение не ждать, пока разработчики программного обеспечения выпустят патчи и обновленные версии программ, совместимые с Windows XP, а сама добавила в операционную систему специальную функцию "режим совместимости", который как раз и настраивается на вкладке Compatibility (совместимость).

    Поставив на этой вкладке галку напротив надписи "Run this program in compatibility mode for" и выбрав одну из предложенных операционных систем (Windows 95, 98, Me, NT или 2000), мы тем самым заставим программу поверить, что она работает не в Windows XP, а в выбранной операционной системе. Стоит отметить, что Windows XP не просто сообщает программе, что она - не Windows XP, но и эмулирует структуру системного реестра соответствующей операционной системы, что позволяет заставить нормально работать в Windows XP большинство из программ, формально не предназначенных для работы в этой ОС, и только некоторые из них (те, что проверяют ядро ОС) не поддадутся на эту уловку и откажутся работать.

    На этой же вкладке, кстати, можно изменить и некоторые другие параметры запуска конкретного приложения - установить разрешение экрана 640х480, уменьшить цветность до 256 цветов и отключить общий для всей операционной системы скин.

    Хочу заменить файл в папке System32, а Windows ругается и не дает. Что делать?

    Не дает - и правильно делает: незачем систему ломать. Это срабатывает система защиты файлов, которая не отключается для загрузочного раздела жесткого диска даже в том случае, если отключить Систему Восстановления (System Restore), убрав соответствующую галку на странице ее настройки.

    С другой стороны, если нельзя, но очень хочется, и при этом вы ясно представляете, что делаете и чем все это дело может закончиться (а итог может быть весьма плачевным), то можно воспользоваться крохотной утилитой по имени SetSfс, позволяющей изменить параметры системы восстановления Windows 2K/XP, а также отключить ее полностью - в том числе и для загрузочного раздела.

    Где находятся те утилиты, о которых говорится в обзоре Windows XP?

    В процессе установки Windows XP они не автоматически не устанавливаются, поэтому их придется инсталлировать уже после установки операционной системы. А находятся они на установочном компакт-диске Windows XP Pro, в папке Support\Tools

    Вроде бы Microsoft уже выпустила пакет дополнений для Windows XP. Откуда его можно скачать?

    Выпущен пакет Powertoys для Windows XP, включающий утилиту для "тонкой" настройки Tweak UI, а также мелкие, но полезные дополнения: Faster User Switcher, Task Switcher, Slide Show Generator, ISO Image Burner и некоторые другие, в том числе графический калькулятор, виртуальный менеджер рабочих экранов и добавочка для управления Windows Media Player из системной панели. Этот пакет уже включен в каталог Softodrom.ru: Powertoys for Windows XP

    Можно ли в XP снимать с аудио-CD цифровой звук?

    Можно - Windows XP допускает передачу аудиоданных с компакт-диска в цифровом виде через IDE-шлейф (без использования проводка, которым обычно соединяют CD-ROM со звуковой картой). Чтобы воспользоваться такой очень полезной возможностью, следует зайти через Control Panel /System на вкладку Hardware, там нажать на кнопку Device Manager и выбрать CD-ROM, в свойствах которого (Properties CD) на одноименной закладке поставить галку напротив "Enable Digital CD-Audio for this CD-ROM device". После этого тот проводок, о котором говорилось выше, можно выбросить.

    Как запустить дефрагментатор из контекстого меню Проводника?

    Загрузите файл context_defrag.vbs. После установки (для этого достаточно щелкнуть по файлу) в контекстном меню Проводника появится пункт defrag, позволяющий быстро запустить дефрагментацию жесткого диска

    Как выставить права пользователям, работающим на компьютере?

    В Windows XP каждому пользователю можно выставить определенные права - что делать разрешается, а что - нет, причем, если пользователей много, их можно распределить по группам, присвоив каждой группе определенные права. Управление пользователями и группами производится через апплет Users Accounts, находящийся в Контрольной панели. Сразу после инсталляции WinXP в этом апплете можно будет увидеть двух пользователей - того, кто был создан в процессе установки (с правами администратора) и второго - гостя (Guest), по умолчанию отключенного. Вообще-то сразу же после установки появляются еще несколько пользователей (например, знакомый еще со времен NT пользователь по имени Administrator), но они не показаны в списке - таков общий принцип построения Windows XP: операционная система предназначена для всех, другими словами - и для чайников тоже, поэтому до "лишнего" можно добраться только после некоторых дополнительных манипуляций. В общем-то, это правильно - меньше дров будет наломано...

    В случае, если вы обладаете правами администратора, апплет Users Accounts даст возможность добавлять или удалять пользователей, менять пользователю пароль или сооветствующую ему картинку-пиктограмму, а также изменять метод входа в систему. По умолчанию при входе в систему показывается экран Welcome screen с пиктограммами и именами пользователей, но, если выбрать пункт "Change the way users log on and off" и убрать в появившемся окне галку с пункта "Use the Welcome screen", вход в систему будет происходить по NT-шному - через окно, в котором предлагается ввести имя пользователя и пароль.

    А где же группы, где возможность редактирования уже существующих пользователей, короче говоря, где все то, что было в NT/2K? - Чтобы получить доступ к контролю над пользователями, который можно назвать "полным", придется заглянуть в апплет Computer Management (Start /Administrative Tools /Computer Management) и кликнуть по плюсику, раскрывающему Local Users and Groups...

    Но и это не все хитрости: есть еще апплет Local Security Setings (он там же, в Administrative Tools), с помощью которого можно, например, изменить время жизни паролей и выставить конкретные права каждой имеющейся группе пользователей.

    Как зайти в систему администатором (пользователь Administrator)?

    Самый простой способ - отключить режим Welcome screen (см. предыдущий вопрос). Кроме этого, залогиниться как Administrator можно, если начать загрузку системы в режиме Safe mode. Наконец, есть и третий, самый хитрый способ: после появления экрана "Welcome screen" дважды нажмите Ctrl+Alt+Del

    Как включить MP3-кодирование с высоким битрейтом?

    Создайте reg-файл (назвав его, например, mp3.reg) следующего содержания:

    Regedit 4
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings]
    [HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding]
    "LowRate"=dword:0000dac0
    "MediumRate"=dword:0000fa00
    "MediumHighRate"=dword:0001f400
    "HighRate"=dword:0002ee00

    и импортируйте его в реестр (щелчок по файлу - установить). После внесения такого изменения в реестр включится встроенный MP3 кодек, но его максимальный битрейт будет ограничен 192 килобитами.
    Второй способ кодирования с высоким битрейтом - использование для кодирования не встроенного, а внешнего MP3-кодека.

    Как изменить интервал синхронизации системных часов компьютера с time-сервером?

    Находим в реестре ключ
    HKEY_LOCAL_MACHINE \SYSTEM \ControlSet001 \Services \W32Time \TimeProviders \NtpClient
    Выбираем параметр SpecialPollInterval и изменяем его значение: оно должно быть равно требуемому интервалу между синхронизациями системного времени, выраженному в секундах (например, 172800 - 2 дня, 43200 - 12 часов)

    Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?

    Режим группирования нескольких открытых окон в одну кнопку - одно из многочисленных не сразу заметных, но очень удобных нововведений. Смысл его заключается в том, что при достижении числа открытых окон определенного значения они группируются и отображаются на панели задач в виде одной кнопки, щелчок по которой вызывает ниспадающее меню со всеми открытыми окнами этой программы. Очень удобная функция, например, при прогулках по Сети с помощью Internet Explorer - уже первый десяток открытых страниц без использования режима группировки донельзя захламляет панель задач.

    Для изменения числа открытых окон программы, которое приводит к включению режима их группировки, нужно запустить Regedit, найти в реестре ключ
    HKEY_CURRENT_USER \Software \Microsoft \Windows \CurrentVersion \Explorer \Advanced
    и изменить параметр TaskbarGroupSize. Если такого параметра нет, то нужно его создать (в виде DWORD) и настроить: щелкаем по параметру правой кнопкой мыши и выбираем в контекстном меню пункт Modify (к примеру, установка для TaskbarGroupSize значения 5 заставит Windows включать режим группировки при пяти открытых однотипных окнах)

    Кстати: а как вообще включить этот режим группировки? Очень просто: щелкаем правой кнопкой по панели задач, выбираем пункт Properties и на вкладке Панель задач ставим галку напротив "Сгруппировать похожие кнопки..."

    Можно ли в окне "Welkome" изменить шрифты на сглаженные (cleartype)?

    Элементарно: открываем реестр, находим ключ HKEY_USERS \.DEFAULT \Control Panel \Desktop, находим в нем параметр FontSmoothingType и изменяем его значение на 2. При следующей перезагрузке системы ждем появления экрана "Welkome", после чего наслаждаемся полученным эффектом...

    А что, в XP нет своего факса?

    Есть, но автоматически при инсталляции операционной системы Cлужба факсов не устанавливается. Чтобы воспользоваться ее возможностями, включающими в себя отправку, прием и контроль факсов, следует через Start / Control Panel открыть апплет 'Установка или удаление программ', щелкнуть там по иконке 'Установка/удаление компонентов Windows', отметить пункт 'Fax Services' и нажать кнопку Next (Далее). После этого последует просьба вставить инсталляционный компакт-диск с Windows XP и начнется процесс установки факс-службы.

    Как удалять файлы, минуя "мусорную корзину"?

    Start -> Run и даем команду gpedit.msc
    В открывшейся консоли выбирает User Configuration, Administrative Templates, Windows Components, Windows Explorer и отмечаем "Do not move deleted files to the Recycle Bin" (не уверен, что подобный пункт есть в Windows XP Home Edition)

    Как переименовать папку аккаунта Administrator?

    Сначала входим в систему под аккаунтом Administrator и создаем в директории Documents and Settings папку с нужным именем. Затем через контекстное меню My computer / Properties / Advanced добираемся до User Profiles, где сопируем профиль администратора в созданную папку. После этого открываем в реестре ключ HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList и находим там ветвь, соответствующую профилю администратора (по значению ключа ProfileImagePath) и исправляем в ней этот параметр на нужный. Теперь можно перелогиниться...

    Как сделать, чтобы при перезагрузке стирался/создавался заново файл подкачки pagefile.sys?

    Открываем реестр и находим ключ
    HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Session Manager \Memory Management
    где выставляем значение "ClearPageFileAtShutdown"=dword:00000001
    Следует отметить, что этот ключ не стирает файл подкачки, а очищает, т.е. заполняет его нулями, но сам файл на диске остается. Такого же рузультата, ксати, можно добиться и через апплет Local Security Policy, находящийся в Administrative Tools (раздел Local Policies, Security Options, ключ Shutdown: Clear virtual memory pagefile when system shuts down).

    Как мне залочить компьютер? Через Crtl+Alt+Del не получается...

    Теперь для этого установлена другая комбинация - Win+L. Кроме этого, можно создать *.cmd файл и лочить машину, запуская его. Содержание этого файла должно быть таким:
    rundll32.exe user32.dll,LockWorkStation

    Как сделать, чтобы зависшие и переставшие отвечать задачи убивались автоматически?

    В реестре по адресу HKCU\Control Panel\Desktop находится ключ HungAppTimeout, значение которого определяет интервал (в миллисекундах), через которое не отвечающее приложение считается зависшим. Кроме этого ключа, в той же ветви находятся ключи WaitToKillServiceTimeout (задаёт время ожидания перед "убийством" зависшей службы), и AutoEndTasks (при установке его значения в 1 системе дается разрешение убивать зависшие процессы самостоятельно).

    Откуда загружаются программы при старте системы? У меня папка Автозагрузка пустая...

    При загрузке операционной системы каманды на запуск некоторых программ даются из системного реестра, где имеется специальная ветвь HLKM \SOFTWARE \MICROSOFT \WINDOWS \CURRENTVERSION \RUN (и аналогичная ...\RUNONCE). В этих ветвях записаны значения, каждое из которых соответствует одной запускаемой при старте программе...
    Только не стоит спешить - если не уверены, что за программа записана, перед удалением обязательно сохраните выбранные строчки (через пункт редактора реестра "экспорт").
    На закуску - маленький секрет. В Windows XP есть утилитка под названием msconfig, которая позволяет очень комфортно управлять параметрами загрузки. Запустить эта утилиту можно через кнопку Start (Пуск) - Run... (Выполнить).

    Можно ли ввести компьютер в состояние hibernate из командной строки?

    Можно. Делается это такой вот командой:
    %windir%\System32\rundll32.exe powrprof.dll,SetSuspendState

    Как изменить time-server, используемый для подстройки системного времени?

    Это можно сделать через апплет "Date and Time Properties", до которого проще всего добраться с помощью двойного щелчка по времени в системном лотке; изменение адреса time-сервера производится в этом апплете на вкладке Internet Time.

    Можно ли отключить сообщение о недостаточности свободного места на диске?

    Можно. Для блокирования появления такого сообщения следует открыть реестр, найти ключ
    HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explоrer
    и вписать в него новый параметр NoLowDiskSpaceChecks типа DWORD, присвоив ему значение 1.

    Как отключить появление предложения об отправке рапорта об ошибке?

    Запускаем утилиту msconfig (кнопка Start -> Run -> msconfig), выбираем вкладку Services и снимаем там галку с пункта Error Reporting Service, после чего нажимаем кнопку ОК и утвердительно отвечаем на предложение перезагрузиться. Или отрицательно, но в этом случае отключение службы отправки рапортов об ошибках произойдет только после следующей перезагрузки операционной системы.

    Можно ли сделать так, чтобы определенная папка открывалась по горячей клавише?

    Можно, но для этого необходимо, чтобы ярлык от этой папки находился на рабочем столе. Находим папку, которую требуется открывать с помощью горячих клавиш, щелкаем по ней правой кнопкой мыши, выбираем пункт Sent To, а в нем - команду Desktop (create Shortcut); или - "захватываем" папку правой кнопкой, передвигаем ее на рабочий стол, отпускаем и в открывшемся меню выбираем пункт Create Shortcuts Here. После этого щелкаем той же правой кнопкой по созданному ярлыку, выбираем в контекстном меню пункт Properties и на вкладке Shortcut в поле Shortcut key (по-русски это, вероятно, будет звучать как Быстрый вызов) впечатываем ту комбинацию клавиш, которая должна будет открывать папку. Необходимо учесть, что в виде горячих клавиш можно использовать как комбинации CTRL+ALT+буква, так и CTRL+SHIFT+буква.

    Как добавить содержимое Рабочего стола в меню Start?

    Находим в системном реестре ключ
    HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders. В нем есть параметр Desktop, имеющий по умолчанию значение "%USERPROFILE%\Desktop". Изменяем это значение на "%USERPROFILE%\Start Menu\Desktop". Кроме этого, нужно будет скопировать папку %USERPROFILE%\Desktop (папка %USERPROFILE% находится в папке Documents and Settings) в папку %USERPROFILE%\Start Menu\Desktop и перезагрузиться, после чего в меню, появляющемся при нажатии на кнопку Start, появится раскрывающееся субменю Desktop.

    Как (и можно ли вообще) уменьшить размеры огромных файлов Pagefile.sys и Hyberfil.sys?

    Начнем по порядку. Pagefile.sys - это своп-файл (или виртуальная память), куда система сбрасывает из оперативной памяти временно ненужные данные. Его размер по умолчанию выбирается самой операционной системой, но он может быть изменен через Start -> Control Panel -> System -> Advanced -> Perfomance -> Settings. После нажатия на кнопку Settings появится двухвкладочное окно, выбираем в нем вкладку Advanced, давим на кнопку Change virtual memory и устанавливаем тот размер виртуальной памяти, который считаем достаточным. Там же, кстати, можно выбрать, на каком из разделов жесткого диска должен находиться своп-файл.
    Hyberfil.sys - файл, используемый системой при переходе в "спящий" режим. Его размер равен размеру оперативной памяти; в принципе, если вы не собираетесь использовать для выключения компьютера спящий режим (Hybernate) (хотя лично я считаю этот режим выключения очень удобным), то можно отключить его (Start -> Control Panel -> Power Options -> Hibernate, где снять галку с Enable Hibernation), после чего файл Hyberfil.sys окажется ненужным...

    Как удалить с рабочего стола все системные иконки, включая корзину?

    Для этого придется или вручную вносить изменения в системный реестр, или - что значительно проще и безопаснее - воспользоваться одной из специализировнных утилит, например - бесплатным комплектом Powertoys for Windows XP производства Microsoft. Powertoys - это набор расширений для XP, включающий, кроме всего прочего, TweakUI - утилиту для настройки пользовательского интерфейса, с помощью которой можно много чего изменить или отключить, в том числе и определить, какие из системных иконок должны показываться на рабочем столе.

    Как отключить автозапуск компакт-дисков?

    Настройка реакции системы на вставленный в привод компакт-диск производится через CD Properties, вызываемые щелчком правой кнопки мышки по CD-диску. Правда, в этом случае нельзя определить действие системы при установке data-CD (уж не знаю почему, но пункта data-CD в CD Properties нет), поэтому, если требуется отключить автозапуск таких дисках, следует во время загрузки диска нажать и удерживать левый Shift.
    Другой способ состоит в правке реестра: находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Services \CDRom и присваиваем паpаметpу Autorun (его тип - REG_DWORD) значение 0.

    Куда подевалась закладка Security в свойствах NTFS-томов и почему так упростилась закладка Sharing?

    Учитывая, что Windows XP - система не только для опытных пользователей, но и для всех остальных, ее разработчики сделали все, чтобы не мозолить начинающим пользователям глаза непонятными им понятиями и обозначениями. К таким понятиям отнесены и Security с Sharing, поэтому, чтобы привести вид вкладок свойств диска к тому виду, к которому уже привыкли пользователи Windows 2000, придется заглянуть в свойства папки (Windows Explorer -> Tools -> Folder Options -> View -> Advanced Settings), где необходимо будет убрать галку с пункта "Use simple file sharing (Recommended)"; после этого в свойствах диска не только появится вкладка Security, но и измениться вкладка Sharing - появится возможность выставлять уровни прав доступа.

    Как назначить диску другую букву?

    Для начала - пара слов о том, как происходит в Windows XP присвоение дискам буквенных обозначений, тем более что происходит оно несколько по другому, чем это делается в Windows 9*/Me.

    В процессе инсталляции Windows XP буква C: присваивается загрузочнуму диску, буквы D:, Е: и так далее - всем остальным обнаруженным при инсталляции жестким дискам, а последняя буква присваивается CD-драйву, причем в дальнейшем при установке в систему новых дисков, например, пишущего CD-привода или еще одного винчестера, им будут присвоены следующие из незанятых букв, то есть у уже установленных дисков буквы не меняются.

    Такой принцип назначения дискам букв, естественно, приводит к тому, что у давно стоящего CD-драйва оказывается меньшая буква, чем у только что установленного винчестера, что может смутить пользователей, перешедших на XP с Windows 9* и привыкших, что у CD-драйвов всегда последние буквы. Но ведь безвыходных положений не бывает: в XP, как и в Windows 9*, можно переназначить дискам другие буквы, вот только делается это несколько по-другому - вручную через консоль управления компьютером (Computer Management). Быстренько добраться до нее можно вот так: Start (Пуск) -> Run (Выполнить):
    compmgmt.msc

    Результатом исполнения этой команды станет открытие консоли, в которой следует выбрать пункт Disk Management. Disk Management - это мощный инструмент для управления дисками, позволяющий, кроме много другого, изменять присвоенные дискам буквенные обозначения.

    А как обстоят дела в WinXP с переименованием загрузочного (или системного) диска?

    И с этим в XP дела обстоят хорошо. Правда, присвоить другую букву загрузочному/системному диску не так просто, как это делается в случае остальных дисков, но в принципе - ничего особо сложного. В качестве примера возьмем да и поменяем буквы у дисков C: и D:

    Для этого запускаем редактор реестра (обязательно под эккаунтом администратора), находим ключ HKLM\SYSTEM\MountedDevices и разрешаем администратору (то есть себе) полный доступ к этому ключу. Делается это через меню Security (Безопасность) -> Permissions (Разрешения).

    После этого находим в HKLM\SYSTEM\MountedDevices букву диска, которую нужно изменить (в нашем случае - "\DosDevices\C:") и меняем ее на любую из тех, что еще не использованы, например, на Z: (т.е. у нас должно получиться вот так: "\DosDevices\Z:").

    Следующий этап - замена буквы у диска D:
    Выбираем \DosDevices\D: и изменяем D: на C:, в результате чего получаем "\DosDevices\C:"
    Наконец, выбираем параметр \DosDevices\Z: и переименовываем его в \DosDevices\D:, после чего перегружаем компьютер.

    Примечание: в случае, если не требуется менять названия дисков с C: на D: и наоборот, а нужно всего лишь заменить C: на еще неиспользованную букву, достаточно изменить значение \DosDevice\С: на любую неиспользуемую букву.

    Два важных замечания:

  • При смене буквы у диска необходимо учитывать, где окажется своп-файл: в случае исчезновения диска, на котором он должен быть размещен, система при перезагрузке сразу после окна входа в систему сообщит, что своп-файл слишком мал, и вновь вернётся в окно логона, причем этот процесс будет продолжаться до бесконечености, вернее, до тех пор, пока вы не поймете, что - увы и ах - необходимо переустанавливать систему. Единственная от этого радость - систему можно будет поставить поверх той, что была установлена, а это позволит не переустанавливать установленные ранее программы.

  • Изменение буквы диска приведет к тому, что перестанут работать те программы, которые используют абсолютный метод адресации, поэтому придется переинсталлировать их или вручную править все пути в реестре, изменившиеся в связи со сменой буквы диска.

    Можно ли отключить работу с zip-архивами как с папками?

    Вообще-то работа с zip-архивами, как с обычными папками - это очень удобно, и есть, как мне кажется, только одна причина для отключения этой возможности - слабая и тормозящая машина. Отключается эта опция очень просто - набором в командной строке
    regsvr32 /u zipfldr.dll
    (обратное включение - regsvr32 zipfldr.dll).

    Как автоматизировать вход в систему - без ввода логина и пароля?

    Start -> Run, вводим команду
    control userpasswords2
    После открытия апплета, служащего для управления учетными записями пользователей, снимаем на вкладке Users флажок напротив "Users Must Enter A User Name And Password To Use This Computer". После нажатия на кнопку ОК появится диалоговое окно "Automatically Log On", где нужно будет указать имя пользователя и пароль.

    Как включить режим UDMA66 на материнских платах, собранных на чипсетах Intel?

    В Windows 2000 и XP этот режим по умолчанию заблокирован, и для его активаации необходимо сделать некоторые изменения в системном реестре.
    Открываем системный реестр и находим ключ
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\ {4D36E96A-E325-11CE-BFC1-08002BE10318}\0000
    после чего создаем в нём новый параметр "EnableUDMA66" типа DWORD и установливаем его значение, равное 1 (установка этого параметра в "0" приведет к блокировке режима).
    Обратите внимание: для активизации установки необходимо перезагрузить Windows.

    Как в Windows XP запускать программы как сервисы?

    Самый простой способ установки запуска программы в качестве сервиса (службы) - использование специальной утилиты-мастера srvinstw.exe из комплекта Windows 2000 Server Resource Kit. Эта утилита позволяет без труда как устанавливать новые сервисы, так и удалять ненужные.

    Кроме этого, в Windows 2000 Server Resource Kit входят специально для этого предназначенные консольные программы instsrv.exe и srvany.exe. Для работы с ними нужно будет войти в систему под учетной записью Администратора (Administrator), скопировать эти файлы в папку %SystemRoot%\System32, а потом выполнить следующую команду:
    instsrv new_service %SystemRoot%\system32\srvany.exe
    где "new_service" - это любое удобное для вас наименование нового сервиса (как раз им и будет обозначаться создаваемый сервис). Обратите внимание на то, что в том случае, если придуманное имя сервиса содержит пробелы, то его нужно будет заключить в кавычки.
    После проведения этой "хитроумной" операции в диалоговом окне 'Управление компьютером' -> 'Сервисы' появится новый сервис, и нужно будет в его свойствах установить способ его запуска - Automatic, если сервис должен запускаться при загрузке системы, Manual - если вручную, или Disabled - отключен.
    Но и это еще не все: в разделе реестра, соответствующем имени создаваемого сервиса ( HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ NEW_SERVICE \ Parameters ) необходимо создать строковый параметр "Application" (без кавычек), значением которого должен быть указан полный путь к исполняемому файлу программы, которую необходимо запускать как сервис.

    • О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
    Copyright © 1999-2002 Е.А.Соболев
    Концепция, дизайн, поддержка: Е.А.Соболев
    Программирование:     Янкин Н.В.


по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Разрешение проблем

Система стала глючить или пропали системные шрифты

Проверяем наличие системных файлов с помощью команды
sfc.exe /scannow
Windows проверит их (шрифты - тоже системные файлы) и при необходимости переустановит недостающие или поврежденные. Если не помогло - запускаем установочный диск Windows XP и выбираем пункт Upgrade to Windows XP (делать это надо из Windows XP).

Вместо русских букв видны какие-то закорючки

Если такое происходит в Фотошопе, то проблема решается так: находим в реестре ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Nls \CodePage и изменяем значение параметра 1252 на c_1251.nls (было c_1252.nls, станет c_1251.nls). Кстати, такая манипуляция помогает иногда и для некоторых других программ.

Если же кракозябры все равно не исчезли, следует проверить правильность установки Languadge Options: запускаем апплет Regional and Languadge Options (он в Контрольной панели) и открываем закладку Regional Options. В разделе Standart and formats имеет смысл выставить "russian", в разделе Location, отвечающем в том числе за системные шрифты - обязательно указать "Russia". Для полного счастья необходимо проверить вкладку Advanced: Language for non-Unicode programs должен быть выставлен в "Russian".

DOS: русские буквы видны, а вот раскладка не переключается

Открываем реестр, находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \KeyboardLayout \DosKeybCodes и изменяем значение 00000409 на "ru". После этого открываем файл autoexec.nt (он находится в папке %SystemRoot%\system32) и добавляем строку
lh %SystemRoot%\system32\kb16.com ru
Перегружаем компьютер и убеждаемся, что теперь в DOS-прилложениях переключение на русскую раскладку происходит по нажатию Ctrl+Right Shift, на английскую - Ctrl+Left Shift.

Для особо забывчивых: создание дискеты для сброса пароля (Password Reset Disk)

С помощью этой дискеты можно будет зарегистрироваться на компьютере даже в том случае, если пароль забыт. Для создания Password Reset Disk следует нажать кнопку Start, выбрать Control Panel, а в ней - User Accounts, и щелкнуть по своему эккаунту. В появившемся окошке в левой колонке (под Related Tasks) есть пункт Prevent a forgotten password - после щелчка по нему запустится мастер создания "спасительной" дискеты.

Эта дискета создается один раз - ее не нужно переделывать при каждой смене пароля, поэтому особое внимание следует обратить на порядок ее хранения: дискета должна храниться в укромном месте, потому что тот, кто найдет и воспользуется ей, сможет войти в систему под вашим именем.

Проблема с инсталляцией программ: программа вроде бы устанавливается, но в конце все исчезает, хотя процесс остается в памяти

По умолчанию временные папки, используемые инсталляторами для распаковки данных, необходимых для установки программы, размещаются по адресу C:\Documents and Settings\[имя пользователя]\. Для некоторых инсталляторов такой путь оказывается слишком длинным: распаковав данные, они затем не могут их обнаружить. Чтобы избежать этого недоразумения, следует определить временной папке путь покороче: заходим на вкладку Advanced в System Properties и нажимаем там кнопку Environment, после чего на открывшейся вкладке меняем пути к TEMP и TMP на, например, C:\Windows\Temp

Установка Windows 9*/Me после установки Windows XP

Прежде всего, следует помнить, что Windows 95/98/Me не понимают файловой системы NTFS, так что установить Windows 9*/Me можно только на диск с FAT16 или FAT32. Но и это еще не все: при инсталляции Windows 9* затирает загрузочный сектор Windows XP, поэтому перед установкой Win9* придется переконфигурировать инсталлятор этой операционной системы. Для этого открываем дистрибутив Windows 9* и ищем там файл msbatch.inf (в случае, если файла в дистрибутиве нет, нужно будет его создать). В msbatch.inf следует вписать следующие две строки:
[Setup]
CleanBoot=0
В виде ответа на еще не заданный вопрос "Так ведь дистрибутив - на CD, как же туда этот файл запихнуть?":
кладем msbatch.inf, например, прямо в корень диска C: (c:\msbatch.inf), после чего запускаем установку Windows 9* со следующим параметром:
setup.exe c:\msbatch.inf
И последнее: имя файла может быть совершенно другим, главное, чтобы в нем были эти две строчки.

Что делать, если после перезагрузки система не находит внешний модем?

Причина "потери" внешнего модема (если модем исправен) кроется в том, что при загрузке Windows XP он был выключен. Для того, чтобы система его определила, достаточно включить модем и произвести поиск новых устройств (делается это через Start -> Control Panel -> Add Hardware) - модем будет найден и включен в список имеющегося оборудования.
В случае, если такой вариант не очень подходит по причине постоянного забывания включить модем перед загрузкой (или перезагрузкой) системы, можно поставить не PnP-версию драйвера для этого модема (поискать её можно в *.inf файле модема). Если такой версии там не окажется, придётся ограничиться установкой какого-нибудь стандартного драйвера, например - Standart Modem. В этом случае, если ваш модем соответствует понятиям операционной системы о стандартном модеме (а для большинства модемов, подключаемых к COM-порту, так оно и есть), система будет постоянно помнить, что модем установлен, и не будет "забывать" о нем вне зависимости от того, включен модем в момент загрузки системы или нет. Правда, в случае установки стандартного драйвера могут исчезнуть некоторые полезные настройки модема (например, возможность включить аппаратную компрессии данных), но ведь любые настройки можно задать через строку инициализации, нужно лишь повнимательнее прочитать инструкцию к модему...
Наконец, есть еще один способ, позволяющий системе не забывать про внешний модем. Заключается он в выключении компьютера переводом его в режим Hibernate (спящий режим).

Почему в режиме Standby не выключаются вентиляторы на блоке питания и процессоре?

Скорее всего, этому мешает одна из установок BIOS. Попробуйте переключить в BIOS (в разделе Power Management Suspend Mode) ST1 на ST3.
Если это не поможет, следует проверить, включен ли ACPI-режим. Для этого нужно перейти через Control Panel в апплет Power Options. При отключенном ACPI-режиме нижняя часть вкладки Advanced апплета Power Options оказывается пустой, при включенном - на ней присутствует несколько пунктов для изменения характеристик включения/отключения компьютера и монитора. Если ACPI-режим включен, но вентиляторы все равно не выключаются, то это может говорить о том, что BIOS не поддерживает такую функцию.

После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...

Наиболее верояная причина - операционная система пытается управлять всей сетью. Для начала попробуйте поставить на эту машину протокол NetBEUI (если он не был установлен), а затем - если не поможет - измените в системном реестре параметры, отвечающие за "амбиции" операционной системы:
HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Browser \ Parameters
IsDomainMaster = FALSE
MaintainServerList = No

Как в Windows XP установить протокол NetBEUI?

Найдите на компакт-диске с дистрибутивом Windows XP папку Valueadd\Msft\Net\Netbeui и скопируйте из нее два файла: nbf.sys в папку %SystemRoot%\System32\Drivers и netnbf.inf в папку % SystemRoot %\Inf. После этого откройте Свойства сети и установите пpотокол NetBEUI.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев


по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Восстановление

Что представляет собой система восстановления Windows XP?

В самом общем плане: System Restore производит "слепок" с системного реестра и создает резервные копии других необходимых для нормального функционирования операционной системы файлов, что дает возможность в случае необходимости произвести возврат системы к прошлому состоянию. Параметры системы восстановления задаются на вкладке System Restore апплета System Properties, до которого можно добраться так: Start/Control Panel/System. Хочу обратить внимание на то, что по умолчанию System Restore включена не только для загрузочного, но и для всех остальных дисков, при этом отключить System Restore штатными средствами ОС можно у всех дисков, кроме загрузочного.
Кроме этого, с целью дополнительной защиты системы от кривых рук некоторых разработчиков программного обеспечения, в Windows XP имеется система защиты файлов

Слышал, что в WinXP есть система восстановления файлов. Она что, все файлы восстанавливает?

Нет, не все. В действительности имеющийся в Windows XP модуль Windows File Protection и вправду восстанавливает файлы, но не все, а только те из исполняемых и системных файлов (*.exe, *.dll, *.ocx и некоторые другие), которые оказались без всякой на то необходимости замененными (например, в процессе инсталляции какой-либо программы), предотвращая тем самым возможные нарушения в работе операционной системы. Дело в том, что для защиты наиболее важных файлов Microsoft ввела их цифровую подпись, и в том случае, если обнаруживается, что происходит замена системного файла другим, не имеющим такой цифровой пописи, следует немедленное оповещение пользователя, а подмененный файл заменяется "правильным", до поры до времени находящемся в специально для этого созданном хранилище. Если же "правильного" файла по какой-то причине на жестком диске не оказывается, то следует предложение вставить в CD-привод компакт-диск, с которого устанавливалась Windows XP...

Система не загружается...

Для того, чтобы упростить восстановление системы после возможного отказа (хоть такое и случается - если сравнивать Windows XP с Windows 9*/Me - крайне редко), нужно будет заранее предпринять некоторые шаги.

Первый способ состоит в резервном копировании всех основных системных файлов: в Properties системного жёсткого диска открываем вкладку Tools и нажимаем на кнопку Backup now... (это же можно проделать через Start -> Programs -> Accessories -> System Tools -> Backup). В открывшемся окне выбираем вкладку Backup и отмечаем галочкой System state, после чего нажимаем кнопку "Start Backup".
Способ этот хорош всем, кроме одного - созданный "резервирующий" файл (*.bkf) будет иметь размер примерно 200 MB, да и восстановить (вернее, исправить возникшие в ее работе ошибки) можно только при работающей системе, так этот способ всего лишь позволяет, восстанавливая системные файлы, не потерять все свои настройки, а значит, кроме прочего, и не переустанавливать заново инсталлирование программы.

Для уменьшения размера создаваемого при резервировании файла до 15-30 MB можно сохранить только содержимое папки \system32\config (полный список файлов реестра можно узнать, если заглянуть реестр: HKEY_LOCAL_MACHINE\System\CotnrolSet\Control\HiveList\ ), причем для этой цели совсем не обязательно проводить все те манипуляции, о которых рассказывалось выше - можно просто скопировать требующиеся для восстановления файлы в другое место, а при возникновении проблем с реестром загрузиться с любой загрузочной дискеты (хотя бы для DOS) и перезаписать сбойный реестр его резервной копией.

Всё это, конечно, прекрасно, но Windows XP может быть установлена не только на FAT, но и NTFS-раздел, и в этом случае обычная дискета не поможет - NTFS-раздел из DOS не виден. Естественно, и в этом случае выход есть, но для решения этой проблемы нужно будет воспользоваться утилитами сторонних разработчиков - например, воспользоваться программой NTFSDOS Pro, позволяющей производить чтение/запись файлов, размещенных на NTFS-разделе, из-под DOS. Кстати, на сайте разратчика NTFSDOS Pro есть подобная же утилита, но для работы с NTFS-разделами из-под Windows 9*.

А если NFSDOS (или какой-нибудь другой подобной утилиты) нет? - Сама Microsoft предумотрела лишь один способ - загрузку с загрузочного компакт-диска Windows XP: в процессе загрузки системы будет предложено два варианта - установить систему заново или восстановить ее с помощью Recovery Сonsole. В случае, если выбрать Recovery Сonsole, поступит предложение ввести пароль Администратора, после чего - если введенный пароль окажется правильным - загрузится интерфейс командной строки. Список всех допустимых команд выводится командой "help", а наиболее важные для них следующие:
перезапись реестра - copy
вывод на экран списка системных служб и драйверов - listsvc
оключение определенной службы - disable (включение - "enable"),
восстановление загрузочных файлов - fixboot
восстановление Master Boot Record - fixmbr

Кстати, загрузить Recovery Соnsole совсем необязательно с CD - ее можно установить на жёсткий диск, м тогда при загрузке можно будет выбирать, загружать ли систему полностью или загружаться в Recovery Console.

Для установки Recovery Console нужно из командной строки в директории i386 дистрибутива Windows XP набрать
winnt32.exe /cmdcons

Учитывая, что набор команд в Recovery Соnsole является очень ограниченным, имеет смысл поставить жесткий диск с неработающей системой на другой компьютер, работающий под управлением Windows XP или 2000, и попытаться спокойно разобраться в причинах краха системы - если и не разберетесь, то уж все данные с NTFS-разделов сможете перенести без проблем...

Как добавить прав в Recovery Console ?

Хорошая мысль - включить максимальные возможности восстановительного инструмента - Recovery Console, только сделать это нужно, не дожидаясь сбоев...
Для разрешения полного доступа к папкам в Recovery Console открываем (под эккаунтом Администратора) Control Panel -> Administrative Tools и запускаем апплет Local Security Policy -> Local Policies -> Security Options, находим там пункт "Recovery Console: Allow floppy copy and access to all drives and folders" и переключаем его в "Enable". Проделав это, перегружаемся в режим Recovery Console и даем команду
SET AllowAllPaths = TRUE

Как восстановить повреждённый загрузчик XP?

Загружаемся в Recovery Console и даем команду
fixboot

Где хранится код активации Windows XP?

Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.

Можно ли в WinXP сделать загрузочные дискеты?

Можно, но для этого придется прогуляться на сайт Microsoft - уж не знаю почему, но необходимый для этого пакет теперь (в отиличие от W2K) не входит в дистрибутив. Адрес страницы загрузки:
http://support.microsoft.com/support/kb/articles/q310/9/94.asp?ID=310994
Обратите внимание: созданные загрузочные дискеты не будут "аварийными" - они предназначены лишь для установки операционной системы на компьютеры, не поддерживающие загрузку с компакт-диска. При загрузке компьютера с установочных дисков Windows XP будут автоматически загружены драйверы привода компакт-дисков, и начнется установка операционной системы.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев


по каталогу
в комментариях
по автору

КАТЕГОРИИ

Система
Интернет и сети
Текст
Мультимедиа
Графика и дизайн
Образование
Бизнес
Игры и развлечения
Заставки
Антиквариат

СОФТОБЗОРЫ

Программа недели
Статьи
Windows XP FAQ
Рассылки Софтодрома

Вокруг софта

» Американские программисты поразились изобретательности спамеров
» Интернет может умереть уже в этом году
» Борцы за права потребителей выступили против DMCA

ПОИСК ФАЙЛОВ

Files.ru
FileSearch.ru

| Главная | Топ-50 | Новинки | Статистика | СофтФорум | UNIX-каталог | Для авторов | Помощь | Лучшее из лучшего | Рассылки Софтодрома | Обратная связь |

Softodrom > Статьи > Windows XP FAQ

Windows XP FAQ

Windows XP и сеть

После подключения компьютера с XP сеть "подвешивается" - на рабочих станциях с Windows 98 не работает сетевое окружение...

Наиболее вероятная причина - операционная система пытается управлять всей сетью. Для начала попробуйте поставить на эту машину протокол NetBEUI (если он не был установлен), а затем - если не поможет - измените в системном реестре параметры, отвечающие за "амбиции" операционной системы:
HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Browser \ Parameters
IsDomainMaster = FALSE
MaintainServerList = No

Как в Windows XP установить протокол NetBEUI?

Найдите на компакт-диске с дистрибутивом Windows XP папку Valueadd\Msft\Net\Netbeui и скопируйте из нее два файла: nbf.sys в папку %SystemRoot%\System32\Drivers и netnbf.inf в папку % SystemRoot %\Inf. После этого откройте Свойства сети и установите пpотокол NetBEUI.

Как отключить службу QoS (Quality of Service). Правда ли, что она ограничивает скорость сети?

Действительно, служба "Quality of Service" резервирует 20% от пропускной способности канала, причем любого - хоть модемного на 14400, хоть гигабитного Ethernet-канала. Особенностью этой службы является то, что даже при удалении службы QoS из свойств соединения пропускная ширина канала не освобождается...
Освободить канал (или настроить QoS) можно следующим образом: запускаем апплет Group Policy (gpedit.msc), находим там Local Сomputer policy и нажимаем на Administrative templates (Административные шаблоны), а затем выбираем Network - QoS Packet Sheduler. Включаем Limit reservable bandwidth и cнижаем Bandwidth limit с 20%, установленных по умолчанию, до 0, или вообще отключаем его.
Обратите внимание: для вступления внесенных изменений в силу требуется перезагрузка.

Windows все время хочет обновиться и пытается лезть в Интернет. Это безобразие можно прекратить?

Можно: Start/Control Panel/System, а там на вкладке Automatic Updates следует отметить последний пункт - "Turn off". После этого следить за появлением обновлений операционной системы придется самостоятельно...

Как включить интернет-защиту?

Одна из новых опций, появившихся в WinXP - файрволл для интернет-защиты. Заходим в свойства того соединения, которое нужно защитить: через Start /Control Panel /Network Connections в контекстом меню нужной иконки выбираем пункт Properties, выбираем вкладку Advanced и отмечаем пункт "Protect my computer and..." (ошибиться вряд ли получится - больше галку там поставить негде)

Можно ли полностью отключить скрытые общие ресурсы (ADMIN$, C$ и т.д.)?

Эти ресурсы в Windows XP (как и в W2K) существуют по умолчанию (доступ к ним возможен только из под эккаунта администратора), причем, если удалить эти ресурсы через "Управление компьютером" (Computer Management) -> "Общие папки", то после перезагрузки они появятся снова, и полностью отключить их можно только с помощью внесения изменений в реестр.
Открываем
HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
и изменениям (или добавляем) следующий параметр:
AutoShareWks (его тип - REG_DWORD) значение 0

Как включить роутинг?

Открываем реестр, ищем ключ
SYSTEM\CurrentControlSet\Services \Tcpip \Parameters и в параметре IPEnableRouter (тип - REG_DWORD) меняем значение 0 на 1.

О перепечатках | Реклама на Софтодроме | Пишите: info@softodrom.ru
Copyright © 1999-2002 Е.А.Соболев
Концепция, дизайн, поддержка: Е.А.Соболев